itmeJP Community


Trouble with Patreon itmebot?

patreon

(Kol_Saresk) #1

Hey @itmeJP and @staff, I don't know if you're aware or not, but there seems to be trouble accessing the itmebot? I think it could be just me, but it's telling me my "Patreon Auth Token has expired." But I have tried logging in and relogging, and making sure my pledge is still current, but still no dice. Is it possible the bot is being worked on?


(Might be Captain Marvel) #2

pinging @Crosseye_Jack specifically to make sure he sees it.

I am getting the same error :slight_smile:


(jjjuser) #3

I'm glad it's not just me, I'm getting the same error


(Ikkuvaljo) #4

Getting the same error here. On iOS, Safari. Bet it's not related to the device or os, but anyway. :slight_smile: Hope you get it fixed soon!


(It's Alive, It's Alive, IT'S ALIVE!!!!) #5

I'll have a look at it.

Side note: Server has been erroring about something overnight (woke up for 45 automated emails from the server) but from an unrelated system. As I've not touched the patreon code in over 2 weeks (my main machine's motherboard died and I'm waiting on it to come back from MSI) my first guess is going to be that the whole server needs a kick up the arse.

Just woke up, so let me get coffee and the like into me and I'll see what the issue is.


(It's Alive, It's Alive, IT'S ALIVE!!!!) #6

I've put some extra logging on the patreon auth tokens to try an catch those (I don't like logging more than I need) and I am investigating them further.


(Might be Captain Marvel) #7

Login works for me now. Thanks Jack <3


(Kol_Saresk) #8

Now, just to clarify, you receive the tokens everytime you hit the "allow" button, correct? Because I was doing that and then it immediately said the token was expired.

It does work now though, thank you. I just wanted to ask the clarification so it could possibly help you look to see if there was another problem, and possibly help in pinpointing it.

Again, thank you for the help and the speedy response.


(It's Alive, It's Alive, IT'S ALIVE!!!!) #9

I think there is a 2nd reason causing it. Looking into it.

Its odd as I've not touched the code that running on itmebot.com for about 3 or 4 weeks now as i'm working on Version 2 of it so for it to stop suddenly like this is odd. I'm turning on more logging to catch the error.

Thing is I'm running on a fucking potato atm, it just took 15 sec's to open a new tab :-s So it's being a pain in the ass to have multiple things open looking for this error. Think I'm just going to buy a new motherboard and eat the £200 I spent on my last one / try and resell it when it comes back from MSI :-s